Get a crash when converting

I tried to convert a set of files from DITA to HTML and OmniHelp. I got a problem with the DCL NT console driver. Here are the details that I've received:

AppName: dcl.exe AppVer: ModName: drxml.dll
ModVer: Offset: 00006a57

Anything I can do to rectify this simply? Is this indicative of something unresolved in the source (I'll admit that I'm using a portion of a document here.)

Current version is

The version currently in the distribution is, and the others (dwhtm and dwrtf) have changed too. I'd get the latest copies. We're making changes fairly often here, so it's best to keep up. ;-)

You should see a log file, d2g_log.txt, and that can be informative too. I'd suggest you start by running one of the conversions on the demo project, at %omsyshome%\demo\DITATestSuite\omnihelp for example. First cd to the output directory, the omnihelp dir in this case, then try:

dcl -f omnihelp ..\DITATestSuite.bookmap

and see if that works. If so, your install is good, and you can go on to try other files.

A portion of a document is fine, long as it's valid DITA. You may get broken xrefs to files that are not included, but I wouldn't expect anything worse. If it doesn't work, we'd like to see a test case (one reason for the Beta, after all), which is best sent using the Support Tickets item on the menu to your left.


Still no closer

I've replaced the modules, and the test suite appears to run fine, but when I run against my content, I still get a crash. Module details are:

AppName: dcl.exe AppVer: ModName: drxml.dll
ModVer: Offset: 00006a57

I suppose I'll open a support ticket so you can attempt to determine what's going on.

Julio J. Vazquez
SDI Global Solutions

Still crashing

I just replaced the files with the latest from here and crash when I try to run the test suite. Now I get a message "Readfile: error opening" and no log. Not sure of the issue right now but will look into this more tomorrow.

Julio J. Vazquez
SDI Global Solutions

Bugs fixed, thanks for the test case.

The details are on the support ticket. The corrected drxml.dll is on the Beta Downloads page, in Components, as We have not updated the full distro zip yet, so be sure and download the component and install it too.

Permissions, maybe?

Check permissions on the directories and the DITATestSuite.bookmap. Sometimes Windows seems to restrict zips that were downloaded, and anything unzipped from them. In their Properties dialogs in Explorer, the Security tab, make sure the files and directories allow "Full Control" for "Everyone".

The permissions were the key

I'm not sure I remember seeing any mention of that in the documentation. You may want to verify and add it (though with an installer, this may not be an issue). Otherwise, set up something so that security doesn' t become an issue for other testers.

The test suite build seems to be okay and I'm assuming that the following error message is only because I don't have pkzip25 on my system:

'pkzip25' is not recognized as an internal or external command,
operable program or batch file.
A subdirectory or file ..\..\_ship already exists.
The system cannot find the file specified.



Julio J. Vazquez
SDI Global Solutions