Starting with a really basic question...

Hey Jeremy...

I'm trying to do a test build, and can't seem to get it to work. Presumably I'm just doing something wrong or missed some install step. I've done the following ..

- extracted into c:\tools\omsys which now contains three folders, common, d2g, and demo.
- created an OMSYSHOME environment variable that points to c:\tools\omsys
- added ";%omsyshome%\common\bin" to my path env var

I open a shell and enter the following ..

C:\Tools\Omsys\demo\DITATestSuite\html>dcl -f html ..\DITATestSupplement.ditamap
dcl: cannot open source file html

Where have I gone wrong?



If you already have Mif2Go installed...

The problem is that there are older versions of dcl.exe and two of the DLLs on your PATH before the new ones. That happened because you already have Mif2Go components installed in \windows\system32; it won't affect anyone who doesn't. There are three solutions:

1. Change the order of directories in your PATH so that the new one comes first. That is, use "%omsyshome%\common\bin;" where the semicolon separator is at the end, and put it first in the PATH. Then the new copies will be used in preference to the older ones.

2. Delete the old Mif2Go components for which there are new DITA2Go versions, from \windows\system32. These would be dcl.exe, dwrtf.dll, and dwhtm.dll. Do not delete drmif.dll, unless you move it too into your new %omsyshome%\common\bin. The next version of Mif2Go will eliminate this problem, as it will also use %omsyshome%\common\bin for its components.

3. Copy the contents of %omsyshome%\common\bin into your \windows\system32 (on 64-bit systems, that's \windows\SysWOW64 instead), overwriting the Mif2Go components already there. If you can't change your PATH, this would be the only option; otherwise, it would be our last choice.

Thanks for spotting this problem! We'll correct the docs accordingly.


Thanks .. that did the trick!